United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Weather Delay] - Multiple MS Counties

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 18:50 UTC

Update

The court systems are now back online for the affected MS counties. Please expect delays as we work through the backlog.
Posted Jun 16, 2025 - 13:37 UTC

Monitoring

Storms have caused power outages in Northern Mississippi, resulting in court system outages in the following counties: Calhoun, Chickasaw, Oktibbeha, Panola, Pontotoc, and Tate. Justice court systems are currently down with no ETA for restoration. Searches are not processing at this time. We are monitoring the situation.
Posted Jun 12, 2025 - 15:38 UTC