United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Yuma, AZ

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 14:32 UTC

Update

Searches are processing as normal in Yuma, AZ and we will continue to monitor the resolution until processing time has stabilized.
Posted Apr 18, 2025 - 15:22 UTC

Monitoring

Please anticipate delays in Yuma, AZ due to staffing shortages. Searches are still processing with an extended TAT. We are monitoring the situation.
Posted Apr 16, 2025 - 16:46 UTC