United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

4/16/2024 - General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 22:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2024 - 23:37 UTC
Identified
High Impact

--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--CA: Los Angeles - Effective February 23, 2024 at close of business, Los Angeles County online index no longer includes the month and year of birth. Researchers must rely on clerk assistance. Please expect extensive delays.

Medium Impact

--OH: Cuyahoga - Municipal court issues have caused processing slowdowns. Please expect delays for the next 1 - 2 weeks.
--GA: Muscogee - Issues with the online index has caused processing slowdowns. Please expect delays.
--CA: Stanislaus - DOBs have been removed from the courthouse terminals. Researchers have to rely on clerk assistance for searches to be completed. Please expect delays.
--NH: All counties - Courthouses are experiencing staffing issues. Please expect delays.
--NV: Washoe - A recent adjustment in clerk procedures has caused a slowdown in searches being processed. Please expect delays as clerks adapt to the new processes.

Low Impact

--TX: Travis - Updates were recently made to the Austin Municipal Court primary index. Please expect delays for searches conducted within this courthouse.
--MS: Holmes - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
-- KY: Pike - The courts are closed Wednesday, 4/17 to Friday, 4/19 for a local festival. Courts will reopen on Monday, 4/22. Please expect delays.
Posted Apr 16, 2024 - 22:21 UTC