Data Status Page

This page contains information about third-party data source disruptions and delays.

Georgia – DLDV Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - normal search processing has resumed.
Posted Jul 10, 2026 - 19:17 UTC

Monitoring

Georgia is currently unable to process DLDV (Driver License Data Verification) inquiries. Searches requiring DLDV verification may experience delays. No ETA for resolution at this time.
Posted Jul 10, 2026 - 18:31 UTC