United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] - Multiple Michigan Counties
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 21:34 UTC
Update
We are continuing to monitor for any further issues.
Posted May 31, 2023 - 02:10 UTC
Monitoring
In response to Michigan's Clean Slate Law, the Antrim, Gladwin, Grand Traverse, Hillsdale, Kent, Leelanau, Saginaw, St. Clair and St. Joseph courts have removed all information from the Public Access Terminal and are not performing any searches at this time. There is no ETA for when the courts will update the system. Please expect extensive delays.
Posted May 25, 2023 - 19:08 UTC