United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Oregon - Emergency System Maintenance

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted 4 days ago. Mar 31, 2025 - 14:26 UTC

Update

Oregon’s case management portal, OECI, is back online and functioning normally. Normal operations have resumed.
Posted 8 days ago. Mar 27, 2025 - 13:47 UTC

Update

Oregon's IT Department is actively working to restore services as quickly as possible and anticipates that the portal will be restored by 8am PT tomorrow (3/27). We will continue monitoring the situation and provide updates as they become available.
Posted 9 days ago. Mar 26, 2025 - 18:12 UTC

Monitoring

Oregon’s case management portal, OECI, is currently unavailable due to emergency system maintenance with no ETA for restoration. Searches are not processing at this time. We are monitoring the situation.
Posted 9 days ago. Mar 26, 2025 - 13:39 UTC