Data Status Page

This page contains information about third-party data source disruptions and delays.

Richmond County, Georgia – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - normal search processing has resumed
Posted Jul 15, 2026 - 03:13 UTC

Monitoring

Automated search processing is temporarily unavailable due to system updates. Some searches are experiencing delays. ETA for restoration is approximately June 27, 2026.
Posted Jun 25, 2026 - 19:29 UTC