Data Status Page

This page contains information about third-party data source disruptions and delays.

St. Tammany Parish County, Louisiana – Court Processing Delays

Incident Report for Checkr Data Status

Update

Updates to the St. Tammany Parish, Louisiana court portal have taken some automated search processing offline. Most searches continue to process normally, though some may experience delays. There is no ETA for resolution at this time.
Posted Jul 15, 2026 - 03:25 UTC

Monitoring

Updates to the St. Tammany Parish, Louisiana court portal have impacted automated search processing. Most searches continue to process normally, though some may experience delays. There is no ETA for resolution at this time.
Posted Jul 15, 2026 - 03:21 UTC