Data Status Page

This page contains information about third-party data source disruptions and delays.

Barrow County, Georgia – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved- normal search processing has resumed.
Posted Jul 09, 2026 - 02:46 UTC

Update

Processing has resumed. Some searches may experience delays. No ETA for resolution at this time.
Posted Jun 25, 2026 - 18:00 UTC

Monitoring

System instability is impacting some automated search processing. Some searches may experience delays. No ETA for resolution at this time.
Posted Jun 18, 2026 - 20:54 UTC