United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] SMITH, TX
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 18:53 UTC
Update
We are now able to process searches in Smith TX. Please continue to anticipate delays as our researchers work through the searches.
Posted Oct 08, 2024 - 19:17 UTC
Monitoring
The public access terminal in Smith, TX is currently down with no estimated time for restoration. We will continue to monitor the situation and notify you of any updates.
Posted Oct 01, 2024 - 20:08 UTC