United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 00:20 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during the following windows (all times Pacific):

- New Jersey: Saturday 11/4 9:30pm until Saturday 11/5 1am
- Kentucky: Sunday 11/5 from 12am until 7am
- Georgia: Sunday 11/5 from 4am until 7am

MVRs requested in these states during these times will not be processed until each scheduled maintenance period is complete.
Posted Nov 03, 2023 - 16:21 UTC