United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] All Massachusetts Courts
Incident Report for Checkr US Data Status
Resolved
9/28/2020: All Massachusetts courts are reopen as of Monday, September 21st.
Posted Sep 28, 2020 - 20:07 UTC
Identified
Expected Fix Date: 9/21/2020

9/17/2020: All Massachusetts courthouses will be closed on Friday, September 18th to honor the memory of Supreme Judicial Court Chief Justice Ralph D. Gants, who passed away earlier this week. Courts are expected to reopen on Monday, September 21st. No searches can be completed until the courts reopen.
Posted Sep 18, 2020 - 00:13 UTC