United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Cook,IL

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 20:54 UTC

Monitoring

The public access terminals in Cook are currently missing identifier information which has resulted in some searches being delayed. At this time, we are only able to complete orders that need an exact DOB and name match for returnability. There is no ETA for restoration. We are monitoring the situation.
Posted Mar 04, 2025 - 17:22 UTC