United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Cobb, GA

Incident Report for Checkr US Data Status

Update

The Cobb, GA site is back online but unstable, searches are processing intermittently. Please continue to anticipate delays. We are monitoring the situation.
Posted Apr 02, 2025 - 20:36 UTC

Update

The Cobb, GA site has been restored however please anticipate delays as we work through the backlog. We are monitoring the situation.
Posted Mar 28, 2025 - 16:13 UTC

Monitoring

Due to maintenance and stability issues of the court website searches for Cobb, GA are not processing at this time and we do not have an ETA for restoration.
Posted Mar 27, 2025 - 21:56 UTC