United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

NY Court Closures
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 17:57 UTC
Monitoring
All courts in the state of NY are closed today for election day. They will resume regular business hours beginning tomorrow morning.
Posted Nov 07, 2023 - 19:23 UTC