United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Massachusetts

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted May 02, 2025 - 15:01 UTC

Update

The statewide PATS in Massachusetts are back up and searches have resumed processing. Please expect delays as our researchers work through the backlog.
Posted Apr 28, 2025 - 16:56 UTC

Monitoring

The PATs across Massachusetts have been experiencing issues throughout the day and are currently down, impacting all counties. Searches are not processing. We are monitoring the situation.
Posted Apr 24, 2025 - 20:16 UTC