United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] OK and TX DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 16:14 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times:

Oklahoma: Thursday 9/8, 6-9pm PT
Texas: Friday 9/9, 5-10pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Sep 08, 2022 - 16:17 UTC