Data Status Page

This page contains information about third-party data source disruptions and delays.

Legacy Site - Records 2004 and older (Multi-County) – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - the legacy site has been restored and normal search operations have resumed.
Posted Aug 08, 2026 - 03:42 UTC

Monitoring

Resolved - the legacy site has been restored and normal search operations have resumed.
Posted Aug 07, 2026 - 23:19 UTC