United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Santa Clara CA

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 14:17 UTC

Update

Automation is restored and is now processing orders. Please note that orders requiring additional research or clerk assistance may have extended TATs.
Posted Mar 19, 2025 - 17:11 UTC

Monitoring

The Santa Clara Superior Court portal is currently experiencing issues. Automation has been paused, and searches are being processed manually. Please expect delays. We are actively monitoring the situation.
Posted Mar 18, 2025 - 14:53 UTC