United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Massachusetts Court Holiday

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 14:22 UTC

Monitoring

All Massachusetts courts will be closed on Monday, April 21st in observance of Patriots’ Day. Search processing will resume once courts reopen on Tuesday, April 22nd.
Posted Apr 18, 2025 - 20:30 UTC