Data Status Page

This page contains information about third-party data source disruptions and delays.

Lamar County, Mississippi – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Normal processing has resumed in Lamar County, MS. No further delays are expected at this time.
Posted Jul 16, 2026 - 23:31 UTC

Update

Normal operations have resumed. Please expect temporarily delay as the queue normalizes.
Posted Jul 15, 2026 - 03:29 UTC

Monitoring

System instability is impacting some search processing. Some searches may experience delays. Processing is expected to resume by July 6th.
Posted Jul 02, 2026 - 19:41 UTC