United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] South Carolina DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 16:57 UTC
Identified
The South Carolina DMV will be performing scheduled maintenance today from 3-7pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Jan 17, 2023 - 17:54 UTC