United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delayed] - Cook, IL
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Oct 06, 2023 - 21:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 02, 2023 - 23:36 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 28, 2023 - 23:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 25, 2023 - 23:35 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 21, 2023 - 00:41 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 18, 2023 - 21:16 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 13, 2023 - 22:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 06, 2023 - 22:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 28, 2023 - 23:14 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 18, 2023 - 18:35 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 10, 2023 - 22:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 03, 2023 - 15:55 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 31, 2023 - 21:24 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2023 - 22:10 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 25, 2023 - 22:41 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 21, 2023 - 23:23 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2023 - 23:14 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 14, 2023 - 23:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 11, 2023 - 00:10 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 05, 2023 - 21:02 UTC
Monitoring
The public access terminals have been experiencing technical difficulties resulting in processing time delays. Currently there is no ETA for a fix. Please expect delays until the public access terminals are fully operational again.
Posted Jun 27, 2023 - 22:22 UTC