United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Riverside County, CA – Court Processing Delays

Incident Report for Checkr US Data Status

Update

Automated search processing has been restored in Riverside County. Some searches may continue to experience delays as the remaining backlog clears.
Posted May 14, 2026 - 16:28 UTC

Update

Automated search processing has been partially restored. Some searches may continue to experience delays; monitoring remains active.
Posted May 08, 2026 - 17:36 UTC

Monitoring

The Riverside County court system is experiencing intermittent stability issues. Searches are continuing to process; however, some searches may experience delays. No ETA for resolution at this time.
Posted Apr 27, 2026 - 21:07 UTC