United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Florida DMV Scheduled Maintenance: 11/13 - 11/16
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 22:49 UTC
Investigating
Due to scheduled maintenance, the Florida DMV will be offline starting at 4pm Pacific on Friday, Nov. 13 and is scheduled to return at 5am Pacific on Monday, Nov. 16. Florida MVRs will be unavailable during this time.
Posted Nov 09, 2020 - 17:18 UTC