United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Closure] Jefferson, TX
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 18:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 14, 2023 - 21:18 UTC
Monitoring
In Jefferson, TX case information will not be available beginning March 3, 2023 as the courthouse transitions to a new online system. The court will not be able to conduct searches during this time. Estimated reopening has been updated to March 20, 2023. This closure affects all searches. Expect delays.
Posted Mar 14, 2023 - 21:17 UTC