United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Possible Cases out of Gwinnett, GA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 01, 2021 - 19:28 UTC
Identified
ETA: Unknown

10/6/2020: As many of you have noticed, possible case details out of Gwinnett, GA are severely delayed. Increased TAT was already an issue because of the pandemic, but starting last week our researchers ran into even more challenges that are impacting their ability to complete work. In addition to a high number of individuals requesting files, the court has implemented the following restrictions:

- The clerks have instituted a 10 file-pull *per day* limit for each person. This was already a standing rule, but is now being strictly enforced.
- Clerks are providing researchers with entire files and all court documentation when files are ordered, researchers must sort through and locate the required case information needed.
- Researchers are limited to 30 minutes to view files.
- Researchers are now prohibited from taking pictures of documents in the files. All information must be handwritten.
- The number of public access terminals (PATs) has been reduced from 4 to 2.
- Chairs have been removed from the PATs.
- Researchers are limited to 30 minutes at the PAT. If this rule is broken after the third warning, researchers stand to be banned for a week. If this rule is broken after the fourth warning, researchers stand to be banned for 30 days.

Our researchers are meeting on the issues in Gwinnett daily in an attempt to devise a plan to increase capacity, but do not have an update at this time.

We sincerely apologize for the inconvenience this may cause and will continue to work with our researchers to try to increase capacity as quickly as possible.

*Please note that this delay does not affect clear results, only searches with possible cases.*
Posted Oct 06, 2020 - 20:35 UTC