United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Missouri

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted May 25, 2023 - 19:06 UTC

Update

We are continuing to monitor for any further issues.
Posted May 18, 2023 - 00:32 UTC

Monitoring

Automation for county and state searches is currently unstable. Please expect delays.
Posted May 12, 2023 - 02:19 UTC