United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Hurricane Delta - Louisiana
Incident Report for Checkr US Data Status
Resolved
10/20/2020: All Louisiana counties are now open, including Cameron, LA.
Posted Oct 20, 2020 - 17:29 UTC
Update
10/15/2020: All Louisiana counties have reopened at this time except for Cameron, LA. No searches can be completed until the court reopens.
Posted Oct 15, 2020 - 16:58 UTC
Monitoring
10/13/2020: All of Louisiana is now open except for the below counties:

Tangipahoa
Lafayette
St. Landry
Jefferson
Orleans

Another update will be posted when all Louisiana counties have reopened.
Posted Oct 13, 2020 - 23:38 UTC
Identified
Expected Fix Date: 10/12/2020

10/8/2020: All Louisiana courts will be closed tomorrow - Friday, October 9th - in preparation of Hurricane Delta. The courts anticipate reopening on Monday, October 12th, but this date could be pushed out depending on how severe the hurricane is. Please note that most counties in Louisiana require in court research, so most searches will not be able to be processed until the courts reopen. However, Orleans, LA is automated and a majority of searches should complete even though the court is closed.
Posted Oct 08, 2020 - 21:35 UTC