United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Tarrant, TX

Incident Report for Checkr US Data Status

Update

Automation has been restored in Tarrant, TX and searches are now processing. Please anticipate delays as we work through the backlog.
Posted Apr 24, 2025 - 15:46 UTC

Monitoring

Due to a new level of authentication in Tarrant, TX are automation has gone offline and searches are not processing at this time. We are actively working to restore access.
Posted Apr 14, 2025 - 19:15 UTC