Data Status Page

This page contains information about third-party data source disruptions and delays.

Yellowstone County, Montana – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

The court has reopened and normal processing has resumed. Some searches may experience additional delays while the queue clears.
Posted Jul 16, 2026 - 19:15 UTC

Update

Processing has resumed. Some searches may experience additional delays while queue resolves.
Posted Jul 08, 2026 - 19:54 UTC

Monitoring

Processing is experiencing a delay due to a court closure. Some searches may take longer than expected. No ETA at this time.
Posted Jul 07, 2026 - 19:51 UTC