United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Suffolk, NY
Incident Report for Checkr US Data Status
Resolved
10/4/2022: The Suffolk, NY court is back open and orders are now being processed. Please expect major delays as our researchers work through the searches.
Posted Oct 04, 2022 - 17:24 UTC
Update
10/3/2022: The Suffolk, NY online index is still down and there is no ETA for when this will be back up and running. We are continuing to monitor this and will notify you of any changes. Please see the county website for additional information: https://www.suffolkcountyny.gov/
Posted Oct 03, 2022 - 19:48 UTC
Update
9/28/2022: The Suffolk, NY online index is still down and there is no ETA for when this will be back up and running. We are continuing to monitor this and will notify you of any changes. Please see the county website for additional information: https://www.suffolkcountyny.gov/
Posted Sep 28, 2022 - 14:44 UTC
Update
The Suffolk, NY online index is still down and there is no ETA for when this will be back up and running. We are continuing to monitor this and will notify you of any changes. Please see the county website for additional information: https://www.suffolkcountyny.gov/
Posted Sep 23, 2022 - 18:19 UTC
Monitoring
The court in Suffolk, NY is currently closed due to a cyber attack. No searches will be processed until the court reopens. There is no ETA for when the court will reopen. We will continue to monitor the situation and will notify you of any changes.
Posted Sep 22, 2022 - 18:16 UTC