United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Georgia DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The GA DMV is back online.
Posted Jul 16, 2024 - 17:09 UTC
Identified
The GA DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Jul 16, 2024 - 14:53 UTC