United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] MA DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The MA DMV is back online and MVRs are once again processing as normal.
Posted Nov 20, 2024 - 22:30 UTC
Update
We are continuing to investigate this issue.
Posted Nov 20, 2024 - 22:29 UTC
Investigating
The MA DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Nov 20, 2024 - 22:29 UTC