United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Upcoming DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Nov 21, 2023 - 16:55 UTC

Identified

The following DMVs will be performing scheduled maintenance during the windows stated below over the coming days (all times Pacific):

Idaho: Wednesday, November 15 from 6pm-9pm
Indiana: Thursday, November 16 from 3:30pm - 8pm
Oklahoma: Thursday, November 16 from 6pm-9pm

MVRs requested in these states during these windows will not be completed until the scheduled maintenance is completed.
Posted Nov 15, 2023 - 18:18 UTC