United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Holiday Closure] Puerto Rico
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 20:22 UTC
Monitoring
The court in Puerto Rico is closed this week due to court holidays. Monday, July 26th was Puerto Rico Constitution Day and tomorrow, Wednesday, July 27th is the Birthday of Dr. José Celso Barbosa. No searches will be processed until the court reopens on Thursday, July 28th, 2022. We will continue to monitor this and will notify you of any changes.
Posted Jul 26, 2022 - 16:34 UTC