Data Status Page

This page contains information about third-party data source disruptions and delays.

Dallas County, Texas – Court Processing Delays

Incident Report for Checkr Data Status

Update

Updates to the Dallas County, Texas court portal have taken some automated search processing offline. Most searches will process normally, though some delays are expected until automation is fully restored. There is no ETA for resolution at this time.
Posted Aug 05, 2026 - 23:15 UTC

Monitoring

System instability has taken some automated search processing offline. Please expect delays. No ETA for resolution at this time.
Posted Aug 05, 2026 - 21:42 UTC