United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Drug and Occupational Health Services Maintenance
Incident Report for Checkr US Data Status
Resolved
The system updates have been completed.
Posted Oct 14, 2024 - 12:03 UTC
Monitoring
Please note, Checkr's drug and occupational health services will be temporarily unavailable Friday, October at at 8 pm CST through October 13 at 8 pm CST due to system updates by our vendor. During this time clinic scheduling, status results and clinics will be affected and unavailable.
Posted Oct 08, 2024 - 16:08 UTC