United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 06, 2023 - 16:36 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Saturday, 3/4
Mississippi: 6am-12pm PT

Sunday, 3/5
Ohio: 3am-3pm PT
Georgia: 5-9am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Mar 02, 2023 - 21:52 UTC