United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

7/1/2024: General Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 00:22 UTC
Monitoring
High Impact

--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--CA: Los Angeles - Effective February 23, 2024 at close of business, Los Angeles County online index no longer includes the month and year of birth. Researchers must rely on clerk assistance. Please expect extensive delays.
--HI: All counties - The court clerk's procedures for processing request has led to slowdowns. We are actively exploring efficiencies to improve TAT.

Medium Impact

--OH: Cuyahoga - Municipal court issues have caused processing slowdowns. Please expect delays for the next 1 - 2 weeks.
--GA: Muscogee - Issues with the online index has caused processing slowdowns. Please expect delays.
--CA: Stanislaus - DOBs have been removed from the courthouse terminals. Researchers have to rely on clerk assistance for searches to be completed. Please expect delays.
--GA: Clayton - As of 6/3/2024, Superior Court cases that need DOB confirmation or are missing sentencing information now require clerk assistance. Researchers used to be able to access this information from in court PATs, but Superior Court access has been removed. Please expect delays.
--MI: Grand Traverse, Antrim, and Leelanau - The Circuit and District court websites for these three counties is currently down. According to the clerks there is no ETA for when they will be fixed. It appears this is also affecting the in-court PATs. Research is halted in these counties for the time being.

Low Impact

--MS: Holmes - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--MS: DeSoto - Court clerk staffing issues are causing increased turn around time. Please expect delays.
--LA: St Tammany - The online website is down while the court transitions to a new case management system. In the meantime, we’re completing searches via court researchers. Please expect delays.
--NV: Carson City - The Carson City District Court records clerk is behind on requests. Please expect delays.
--NY: Tioga - The research method changed in mid-March. Researchers used to be able to conduct research on a PAT, but now all requests must be submitted to the clerks. Clerks will only process 10 searches a day. Going forward, please anticipate increased TAT in this county.
--TX: San Patricio and San Jacinto - These courts are transitioning to a new case management system with no ETA for completion. All searches are on hold while the system migration takes place.
--OH: Butler - Issues with the online index have caused processing slowdowns. Please expect delays.
Posted Jul 01, 2024 - 15:22 UTC