United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Closure] MITCHELL, GA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 23:08 UTC
Monitoring
The county is closing for two weeks starting on 5/15/2023 to move the clerk's office to a new location. Searches will be on hold until the court reopens on 5/30/2023.
Posted May 11, 2023 - 18:31 UTC