Data Status Page

This page contains information about third-party data source disruptions and delays.

Kankakee County, Illinois – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved- normal search processing has resumed.
Posted Jun 30, 2026 - 06:36 UTC

Update

Automated processing is resuming. Some residual delays may remain while the queue clears. There is no ETA for resolution at this time.
Posted Jun 25, 2026 - 18:07 UTC

Update

Automated processing is resuming. Some residual delays may remain while the queue clears. There is no ETA for resolution at this time.
Posted Jun 16, 2026 - 14:54 UTC

Monitoring

Updates to the Kankakee County, Illinois court portal have impacted automated search processing. Searches continue to process, though some delays are expected. There is no ETA for resolution at this time.
Posted Jun 15, 2026 - 15:31 UTC