United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delayed] Hinds, MS
Incident Report for Checkr US Data Status
Update
We are continuing to monitor for any further issues.
Posted Sep 21, 2023 - 00:41 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 18, 2023 - 21:16 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 13, 2023 - 22:47 UTC
Monitoring
Hinds, MS court system was compromised and has been taken offline until further notice. Searches are unable to be completed at this time. The court clerks do not have an estimated time for when services will be operational again. The IT department is actively working to restore the system. We will continue to monitor the situation closely.
Posted Sep 08, 2023 - 20:05 UTC