United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] KENT,MI
Incident Report for Checkr US Data Status
Resolved
Checkr is not impacted by this outage.
Posted Dec 20, 2024 - 17:17 UTC
Monitoring
The Kent district court index is down for maintenance with no ETA on restoration. Please expect delays on all Kent searches while the outage persists We are actively monitoring the situation and will keep this page updated with any improvements.
Posted Dec 20, 2024 - 16:40 UTC