Automated search processing has resumed across Butler, Hamilton, Highland, Lake, Montgomery, and Summit counties.
In Auglaize, Cuyahoga, Muskingum and Tuscarawas counties, automation remains offline and searches may continue to experience delays. No ETA for resolution at this time.
Posted Aug 20, 2026 - 21:49 UTC
Update
System instability continues to impact automated search processing across the following Ohio counties: Butler, Cuyahoga, Hamilton, Highland, Lake, Montgomery, Muskingum, and Summit. Some searches may experience delays. No ETA for resolution at this time.
Posted Aug 05, 2026 - 00:18 UTC
Monitoring
System instability has taken automated search processing offline across the following Ohio counties: Butler, Cuyahoga, Franklin, Hamilton, Highland, Lake, Lucas, Montgomery, Muskingum, Summit, and Trumbull. Searches requiring manual fulfillment may experience delays. No ETA for resolution at this time.