United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] North Dakota DMV 5/3 to 5/9.
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 06, 2022 - 17:51 UTC
Identified
North Dakota DMV plans to have an extended outage from 5/3 to 5/9. No MVRs requested during this time will be completed. We apologize in advance for the inconvenience.
Posted Apr 29, 2022 - 22:08 UTC