United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] BOLIVAR, MS

Incident Report for Checkr US Data Status

Resolved

The Bolivar MS Justice Court terminal is back up and orders are processing as normal.
Posted Mar 10, 2025 - 19:11 UTC

Monitoring

The Bolivar MS Justice Court terminal is currently down and searches cannot be completed at this time. It is estimated that the terminal will be restored by the end of this week. We are actively monitoring the situation.
Posted Mar 05, 2025 - 18:14 UTC