United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Florida DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Resolved

The Florida DMV is back online and MVRs are once again processing as normal.
Posted Mar 31, 2025 - 17:11 UTC

Monitoring

The Florida DMV will be performing scheduled maintenance today from 4pm PT through Sunday, March 30 at 12pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Mar 28, 2025 - 19:41 UTC