United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Closure] Bexar, TX System Migration
Incident Report for Checkr US Data Status
Resolved
Bexar, TX has transitioned to a new case management system. All searches are once again processing.
Posted Jun 28, 2024 - 14:32 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 26, 2024 - 17:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2024 - 20:50 UTC
Monitoring
Bexar, TX is transitioning to a new case management system. All searches are on hold while the system migration takes place.
Posted Jun 04, 2024 - 18:39 UTC