United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

7/23/2024 - General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 22:26 UTC
Monitoring
High Impact

--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--CA: Los Angeles - Effective February 23, 2024 at close of business, Los Angeles County online index no longer includes the month and year of birth. Researchers must rely on clerk assistance. Please expect extensive delays.
--HI: All counties - The court clerk's procedures for processing request has led to slowdowns. We are actively exploring efficiencies to improve TAT.

Medium Impact

--GA: Muscogee - Issues with the online index has caused processing slowdowns. Please expect delays.
--CA: Stanislaus - DOBs have been removed from the courthouse terminals. Researchers have to rely on clerk assistance for searches to be completed. Please expect delays.
--GA: Clayton - Superior Court cases that need DOB confirmation or are missing sentencing information now require clerk assistance. Researchers used to be able to access this information from in court PATs, but Superior Court access has been removed. Please expect ongoing delays.
--GA: Newton - The court is experiencing connectivity issues, please expect continued delays.

Low Impact

--MS: DeSoto - Court clerk staffing issues are causing increased turn around time. Please expect delays.
--LA: St Tammany - The courts have moved to in-court research. Please expect some continued delays.
--NV: Carson City - The Carson City District Court records clerk is behind on requests. Please expect delays.
--NY: Tioga - The research method changed in mid-March. Researchers used to be able to conduct research on a PAT, but now all requests must be submitted to the clerks. Clerks will only process 10 searches a day. Going forward, please anticipate increased TAT in this county.
Posted Jul 23, 2024 - 20:44 UTC